Back to overview
Downtime
Server down
Jan 07 at 08:11am PST
Affected services
lemmy.ca
Resolved
Jan 07 at 08:42am PST
We're back again....
Affected services
lemmy.ca
Updated
Jan 07 at 08:36am PST
They seem to be replacing our power supply again
Affected services
lemmy.ca
Created
Jan 07 at 08:11am PST
Ahhhh the server is down again. Talking to OVH to get us back up ASAP.
Affected services
lemmy.ca